There was a fair amount of bumbling to get this hook named in the first the 
place, and clearly the name isn't satisfactory still. I think it's 
difficult because different names make sense depending on the perspective 
you look at the hook from (as Brice suggested). Maybe it would be useful to 
draw up a type/provider lifecycle picture that makes the terminology clear 
and indicates where all existing hooks are executing (the older hooks, e.g. 
'flush', are even less descriptive) and drop that into the Puppet doc 
website somewhere? Especially as more hooks are added, I think this would 
be helpful. 

Eric

On Friday, March 7, 2014 5:01:13 AM UTC-6, Brice Figureau wrote:
>
> On Thu, 2014-03-06 at 20:16 -0800, Jeff McCune wrote: 
> > This is just a continuation of a previous thread as to not hijack the 
> > original discussion. 
> > 
> > 
> > The question that needs a decision is, should post_resource_eval be 
> > renamed given the context that it's currently implemented as a hook 
> > into the point after all resources for a provider are evaluated and we 
> > might want a hook into the point after each discrete resource is 
> > evaluated? 
> > 
> > 
> > Nan agrees it should be renamed hence the need for a decision. 
>
> +1 for renaming, but I'd call that hook post_transaction (or 
> post_transaction_apply). 
>
> "Catalog evaluation" might mean a different thing based on which catalog 
> you are referring to (ie RAL, containment...). 
>
> -- 
> Brice Figureau 
> My Blog: http://www.masterzen.fr/ 
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"Puppet Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to puppet-dev+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/puppet-dev/b1da33e5-512b-4763-b12e-3705820d8221%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to