Antoine Pitrou <pit...@free.fr> added the comment:

About dedup_const_planb.patch: _PyCode_AddObj() should be added to 
Include/code.h, even if it's private (rather than declared extern in 
peephole.c).

About consts_test.patch: "def mapping" deserves a better name, and perhaps a 
comment or explanation. Same for "def fix".

About unused_consts.patch:

- code like
    constuse = (int *)PyMem_Malloc(numconst * sizeof(int));
is better spelt
    constuse = PyMem_NEW(int, numconst);

- why the "#ifndef NDEBUG" path?

You probably need to regenerate this patch against latest hg, by the way...
Thanks for posting this.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue11462>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to