Ralf Schmitt added the comment: I think having a lock here is unnecessary. The following code should work:
def _decrement_pending_calls(self): if self.num_pending_calls == len(self.finished_futures): self.event.set() (well, maybe the method should also be renamed then) ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue14406> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com