New submission from gd2shoe:

I'm constantly finding myself writing itty-bitty try blocks like such:

process stuff
try : someSubProcess.kill()
except : pass
process stuff

I realize this isn't a rigorous use of except, but it's good enough for a vast 
majority of what I need it for.  Still, it adds excess verbiage and makes code 
slightly harder to read.

All I need except to do most of the time is suppress exceptions.  I think the 
language could be enhanced by making the except clause implicit.

the above would become:

process stuff
try : someSubProcess.kill()
process stuff

The intent remains clear.  The code is cleaner and easier to read.

This does not happen often in rigorous code, but grep does find 3 counts in 
standard modules and 9 counts in numpy.  I'm certain most prototype code (like 
mine) would greatly benefit.  (My current 300 line project uses 4 so far.)

----------
components: Interpreter Core
messages: 169326
nosy: gd2shoe
priority: normal
severity: normal
status: open
title: Feature request, implicit "except : pass"
type: enhancement
versions: Python 2.7, Python 3.4

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue15804>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to