Antoine Pitrou added the comment:

In:

+                    except:
+                        sys.excepthook(*sys.exc_info())

I would write "except Exception" instead. You don't want to trap e.g. 
KeyboardInterrupt.

For clarity, I would also add "_dirty = False" at the finalize top-level.
Otherwise, looks fine to me.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue15528>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to