Nick Coghlan added the comment:

Just one final design philosophy comment from me (I know it isn't needed since 
Guido already ack'ed the suggestion):

As far as the lessons learned from the historical startswith() case go, 
avoiding taking up the positional slots with optional flags and configuration 
parameters is one of the big reasons we added keyword only arguments (with the 
other being readability at the call site).

I agree we need to be cautious with API complexity, I just think in this case 
clean handling of empty iterators is a net win (so long as we rule out the 
conceptually broken case of combining the new parameter with multiple 
positional arguments).

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue18111>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to