Jim Jewett added the comment:

I'm still not seeing why these changes are sufficiently desirable to justify 
the code churn.  Nor am I seeing test or doc changes that would explain the 
advantages of the new way, and prevent future regressions.

I agree that the changes would make the signatures better for the typical use 
cases for this particular widget -- but wouldn't they also break the common 
interface for the "set" and "activate" methods across several types of tkinter 
widget?  

If so, then instead of changing or restricting the method, it would be better 
to add examples (and maybe even an explanation) to the documentation (including 
the docstring).




In particular:

(1)  Why change actrivate's parameter from "index" to "element"?  I agree that 
"element" is a better name for the normal case, but 
https://docs.python.org/dev/library/tkinter.html#the-index-parameter
strongly suggests that "index" is more consistent with the rest of tkinter, and 
that there are use cases wehre "index" is the right name.  If that is not true, 
please say so explicitly, at least in comments.

(2)  Why change the "set" method?  I understand that a more specific signature 
is desirable, and I assume that other values would be ignored (or raise an 
exception), but the set method seems to have an existing API across several 
widgets -- and that shouldn't be broken lightly.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue6167>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to