Vinay Sajip added the comment:

> _srcfile is only used to identify the caller's stack frame

Not quite. It's also used to indicate whether findCaller() should be called at 
all: setting it to None avoids calling findCaller(), which might be desirable 
in some performance-sensitive scenarios.

So if you mean "just call _get_module_filename() instead of accessing 
_srcFile", that won't do. If you mean "set _srcFile to the return value of 
_get_module_filename()", that might work, if I e.g. move the _srcFile 
definition to after addLevelName (say) and do just

_srcFile = addLevelName.__code__.co_filename

How does that sound?

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue21709>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to