Ezio Melotti added the comment:

I left a few comments on rietveld.
The patch should also include documentation.

> Class decorator approach looks less obvious to me. [...]
> But encountering the unittest.base_class decorator, I need to look in
> the documentation and/or sources to understand how it works.

I also agree that seeing @testBaseClass (the current name in the patch) gives 
very little indication of what's going on, but perhaps that could be fixed with 
a better name.
The two importants things are that the class is ignored/skipped, and that this 
doesn't propagate to the subclasses (as one might expect).
Would something like @ignoredBaseClass/@skippedBaseClass be better?  Another 
options could be a more explicit @dontRunBaseClassTests, even though I don't 
particularly like the name.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue14534>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to