Martin Panter added the comment:

The current proposed text would be rendered something like this:

'''
TemporaryFile, NamedTemporaryFile, TemporaryDirectory, SpooledTemporaryFile are 
high-level interfaces which provide automatic cleanup and can be used as 
context managers. mkstemp() and mkdtemp() are lower-level functions which 
require manual cleanup.
'''

My opinion is it is very often worthwhile rewording the sentence. It is awkward 
to read at the moment, especially if you are trying to skim over it without 
reading the whole paragraph. Unlike in Python, in English there’s always more 
than one way to do it. Perhaps you could consider this version instead:

'''
The TemporaryFile, NamedTemporaryFile, TemporaryDirectory, [and] 
SpooledTemporaryFile classes are high-level interfaces which provide automatic 
cleanup and can be used as context managers. The mkstemp() and mkdtemp() 
functions are lower-level, and require manual cleanup.
'''

Only about three more words, and not particularly convoluted. But if you 
disagree, I can live with it, since there are plenty more examples of this in 
the Python documentation and elsewhere :)

Other than that, I think the patch is good.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue23725>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to