New submission from Aviv Palivoda:

Currently zlib.compress allow only positional arguments. For code readability 
reasons i think that we should allow the level argument to be keyword argument. 
Now when someone uses zlib.compress he will be able to do 
zlib.compess(some_data, level=7) instead of zlib.compress(some_data, 7).

There is a patch included with the change.

----------
components: Extension Modules
files: zlib-compress-level-keyword.patch
keywords: patch
messages: 259266
nosy: nadeem.vawda, palaviv, twouters
priority: normal
severity: normal
status: open
title: zlib.compress level as keyword argument
type: behavior
versions: Python 3.6
Added file: http://bugs.python.org/file41760/zlib-compress-level-keyword.patch

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue26243>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to