Zachary Ware added the comment: I agree that what is currently in the docs is technically correct. The section on the power operator:
power ::= await ["**" u_expr] should be read as: power ::= (["await"] primary) ["**" u_expr] just as the definition of 'u_expr' below should be read as: u_expr ::= (await ["**" u_expr]) | "-" u_expr | "+" u_expr | "~" u_expr and 'await' should be read as: await ::= ["await"] (atom | attributeref | subscription | slicing | call) Each definition builds upon previous ones. However, it is confusing. Could a name other than "await" be used, since "await" is easily confused with the keyword await? ---------- nosy: +zach.ware _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue26156> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com