Paul Moore added the comment:

Zipapp uses path objects throughout, so making the filter function take a path 
object is consistent with that. I guess modifying PyZipFile to take either a 
string or a path object would be possible.

As for the relative path, that's deliberate as I expect that a common use case 
will be to exclude a directory, and doing that via

    lambda pth: pth.parts[0] != 'dir_to_exclude'

is a simple possibility. Having to do this with an absolute path would just 
require the user to make the path relative, and we've already done that in 
zipapp so why duplicate the work?

So I guess I'm saying I want to keep both those choices. Do you think this is a 
sufficient problem that we should *not* use the same name? Any suggestions on a 
better name (or should we stick with the original ``include_file``)?

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue31072>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to