New submission from amjad ben hedhili <amjadbenhedh...@gmail.com>: It will be much of improvement for readability to write:
my_list = ["John", "Richard", "Alice", 1, True, 2.1, "End"] a, b, c = my_list[1, 3, -1] instead of: my_list = ["John", "Richard", "Alice", 1, True, 2.1, "End"] a, b, c = my_list[1], my_list[3], my_list[-1] ---------- messages: 314095 nosy: amjad ben hedhili priority: normal severity: normal status: open title: Syntax to get multiple items from an iterable type: enhancement _______________________________________ Python tracker <rep...@bugs.python.org> <https://bugs.python.org/issue33103> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com