Nick Coghlan <ncogh...@gmail.com> added the comment:

Reviewing this again now, I think my previous naming suggestion is problematic, 
as it encourages conflating two different concepts that use similar syntax:

* collecting arbitrary positional parameters in a tuple (VAR_POSITIONAL) or 
arbitrary keyword parameters in a dictionary (VAR_POSITIONAL, VAR_KEYWORD)
* unpacking function arguments from iterables (BUILD_VAR_POSITIONAL) or 
mappings (BUILD_VAR_KEYWORD)

I think the fix for that error is straightforward though: replace "VAR" with 
"ARG" in the new opcode names, giving:

* BUILD_ARG_POSITIONAL
* BUILD_ARG_KEYWORD

That should also read nicely with Zackery's documentation updates.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue30076>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to