Terry J. Reedy <tjre...@udel.edu> added the comment:

In msg266115, Robert Collins suggested  "add a different name and deprecate 
assertCountEqual".

In msg266184, Gregory Smith said "not against adding a new name if it makes 
glorious sense, but we should not remove the old names from unittest as that 
causes unnecessary pain (based on past experience)."

Others suggested status quo.

In msg352556, Michael Ford said "I like assertPermutation", but did not reopen 
the issue.

Coming at this fresh, via the PR that patches idlelib, my first thought was 
that assertCountEqual meant assertEqual(len(a), len(b)).  So the issue seems 
real.  assertPermutation is much better to me and I would like it added.

In unittest/case.py, PR 16228 renames assertCountEqual to assertPermutation and 
adds assertCountEqual as an alias, with no plan for deprecation and removal, as 
eventually done with other duplicates.

However, the PR also immediately renames all instances of assertCountEqual in 
the stdlib.  Perhaps 1/4 of these are in idlelib tests.  Much as I prefer the 
new name, this is unacceptible as it immediately makes backporting test changes 
in these areas (and I plan to make some) a manual process.  So I don't want 
IDLE tests renamed until 3.8 is off maintenance and the name change can be made 
in all maintenance versions at once.

I leave it to the rest of you to decide on the rest of the stdlib.

----------
nosy: +terry.reedy
versions: +Python 3.9 -Python 3.6

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue27071>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to