Ma Lin <malin...@163.com> added the comment:

Recent commits for longobject.c

    Revision: 5e63ab05f114987478a21612d918a1c0276fe9d2
    Author: Greg Price <gnpr...@gmail.com>
    Date: 19-8-25 1:19:37
    Message:
    bpo-37812: Convert CHECK_SMALL_INT macro to a function so the return is 
explicit. (GH-15216)

The concern for this issue is: implicit return from macro.
We can add a comment before the call sites of CHECK_SMALL_INT macro, to explain 
that there is a possible return.

    Revision: 6b519985d23bd0f0bd072b5d5d5f2c60a81a19f2
    Author: animalize <animal...@users.noreply.github.com>
    Date: 19-9-6 14:00:56
    Message:
    replace inline function `is_small_int` with a macro version (GH-15710)

Then this commit is not necessary.

    Revision: c6734ee7c55add5fdc2c821729ed5f67e237a096
    Author: Sergey Fedoseev <fedoseev.ser...@gmail.com>
    Date: 19-9-12 22:41:14
    Message:
    bpo-37802: Slightly improve perfomance of PyLong_FromUnsigned*() (GH-15192)

This commit introduced a compiler warning due to this line [1]:
    d:\dev\cpython\objects\longobject.c(412): warning C4244: “function”: from 
“unsigned long” to “sdigit ”,may lose data

[1] the line:
    return get_small_int((ival)); \
https://github.com/python/cpython/blob/master/Objects/longobject.c#L386

    Revision: 42acb7b8d29d078bc97b0cfd7c4911b2266b26b9
    Author: HongWeipeng <961365...@qq.com>
    Date: 19-9-18 23:10:15
    Message:
    bpo-35696: Simplify long_compare() (GH-16146)

IMO this commit reduces readability a bit.

We can sort out these problems.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue37812>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to