New submission from Matthias Bussonnier <bussonniermatth...@gmail.com>:

better error/exception name for re.compile error. 

Currently the error raise by re.compile when it fails to compile is `error` 
defined in sre_constants.py: 

```
class error(Exception):
    """Exception raised for invalid regular expressions.

```

This is quite disturbing as most exception start with an uppercase and have a 
tiny bit more descriptive name. 

Would it be possible to have it renamed as something more explicit like 
`ReCompileError`, and still keeping the potential `error` alias as deprecated ?

----------
components: Regular Expressions
messages: 357867
nosy: ezio.melotti, mbussonn, mrabarnett
priority: normal
severity: normal
status: open
title: better name for re.error Exception class.

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue38981>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to