Zachary Kneupper <zachary.kneup...@gmail.com> added the comment:

> Any objections to linear_regression(x, y) -> (slope, intercept)?


I think `linear_regression(x, y)` would be intuitive for a wide range of users.

Just to clarify, is the proposal to return a regular tuple instead of named 
tuple?

Would we do this:

    return (slope, intercept)

and not do this:

    return LinearRegression(intercept=intercept, slope=slope)
 
and not do this:

    return Line(intercept=intercept, slope=slope)
 
?

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue44151>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to