Nick Coghlan <ncogh...@gmail.com> added the comment:

PR has been updated with a new API proposal prompted by Mark's review comments 
on the original proposal.

* Rename "pycore_frame.h" to "pycore_framedata.h"
* Rename the _interpreter_frame struct to _Py_execution_frame
* Rename the type from InterpreterFrame to _Py_framedata
* Rather than 6 fields with no prefix, and 6 fields with the "f_" prefix, 
_Py_framedata fields now consistently have no prefix (globals, builtins, 
locals, code, lasti, and stack are affected by this)
* Use "fdata" rather than a mixture of "frame" and "f" for frame data variables
* Generators and coroutines use ``gi_fdata`` (etc) rather than ``gi_xframe`` as 
their field name
* Frame objects use ``f_fdata`` rather than ``f_frame`` as their field name
* Thread states use ``fdata`` rather than ``frame`` as their field name
* Consistently use _Py_frameobject as the access function prefix, rather than a 
confusing mixture of _PyFrame and _PyInterpreterFrame
* Leave the name of _PyThreadState_PushFrame alone
* Leave the name of _PyThreadState_PopFrame alone

----------
title: Code readability: rename interpreter frames to execution frames -> Code 
readability: rename InterpreterFrame to `_Py_framedata`

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue44800>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to