Jeffrey Yasskin <jyass...@gmail.com> added the comment:

In this case, "acquire" isn't ambiguous. All the other lock types actually 
acquire a write lock, so it makes sense to have the operation with the same 
name they use also acquire a write lock on this object.

I realized that read/write locks are actually shared/exclusive locks, which 
might form the basis for a name that doesn't collide with RLock. Boost 
(http://www.boost.org/doc/libs/1_43_0/doc/html/thread/synchronization.html#thread.synchronization.mutex_types.shared_mutex)
 uses shared_mutex for the concept, so SLock or SELock? There are some 
algorithms that write while the lock is acquired non-exclusive, so "shared" is 
actually a better name for the concept, even though posix and Java used 
read/write.

The possibility of lock downgrading (turning an exclusive lock into a shared 
lock, without allowing any other exclusive acquisitions in the mean time) might 
inform your decision about how to name "unlock".

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue8800>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to