Michael Foord <mich...@voidspace.org.uk> added the comment:

Renaming and aliasing methods has a cost. It confuses users of the old names 
(including future users - the current API is now baked into django 1.3 unless I 
can get an update done in time for them to change the version they're using). 
People who use autocomplete or introspection (dir) to explore the APIs will 
also still come across the old names. Given that unittest has just changed a 
lot a further radical change is 'unfortunate'.

However, for both the regexp methods and the Items method the names are 
actually misleading.

For assertItemsEqual Raymond suggests assertElementCountsEqual. See issue 10242.

For the regexp methods we should use assertRegexp - this is shorter, not 
misleading and consistent with assertRaisesRegexp.

We should leave the gt / le / lt methods as they are. There is less consensus 
that these methods should be changed anyway.

The documentation can be improved by moving *all* the deprecated methods (new 
and old) out of the main documentation and into a separate section at the end 
of the documentation.

The type specific asserts we should also move into their own section and out of 
the main documentation. This means users who discover don't have to go to the 
source (there are online references) but they are out of the main documentation.

Hopefully everyone is only equally unhappy with this resolution.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue10273>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to