Eric Smith <e...@trueblade.com> added the comment:

I agree. It would be nice, but the impact on existing code is too large. I can 
easily imagine someone parsing the output of "print(somecomplexnumber)" and not 
considering spaces.

For the record, it would require changing complex.__repr__  (which is also 
complex.__str__) and complex.__format__.

Now that I look at the code, it seems that complex_format is only called from 
one place (complex_repr), with fixed parameters. It could be moved into 
complex_repr for what I think is a small improvement in readability.

----------
nosy: +eric.smith

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue10621>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to