At 08:19 PM 6/26/2005 +0100, Michael Hoffman wrote:
>On Sun, 26 Jun 2005, Phillip J. Eby wrote:
>
> > * drop getcwd(); it makes no sense on a path instance
>
>Personally I use path.getcwd() as a class method all the time. It
>makes as much sense as fromkeys() does on a dict instance, which is
>technically possible but non-sensical.

It's also duplication with os.path; I'm -1 on creating a new staticmethod 
for it.


>Reinhold Birkenfeld wrote:
>
> > One more issue is open: the one of naming. As "path" is already the
> > name of a module, what would the new object be called to avoid
> > confusion? pathobj?  objpath? Path?
>
>I would argue for Path. It fits with the recent cases of:
>
>from sets import Set
>from decimal import Decimal

I like it too, as a class in the os module.

_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to