On 10/31/07, Fred Drake <[EMAIL PROTECTED]> wrote:
> If I had to choose built-in names, though, I'd prefer "property",
> "propset", "propdel".  Another possibility that seems reasonable
> (perhaps a bit better) would be:
>
>    class Thing(object):
>
>        @property
>        def attribute(self):
>            return 42
>
>        @property.set
>        def attribute(self, value):
>            self._ignored = value
>
>        @property.delete
>        def attribute(self):
>            pass

+1 on this spelling if possible.  Though based on Guido's original
recipe it might have to be written as::

      @property.set(attribute)
      def attribute(self, value):
          self._ignored = value

STeVe
-- 
I'm not *in*-sane. Indeed, I am so far *out* of sane that you appear a
tiny blip on the distant coast of sanity.
        --- Bucky Katt, Get Fuzzy
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to