Antoine Pitrou <[EMAIL PROTECTED]> writes:

> The problem with "fail*" is that you get names like "failIfNotEqual"

That would better be written (preferring PEP 8 names)
"fail_unless_equal".

> (or perhaps even "failUnlessNotEqual")

idem, "fail_if_equal".

> which are double negatives

Exactly. With "if" and "unless" at our disposal, we can avoid such
double negatives.

> (not to mention "assert" is a widely established name in various
> languages - including Python - for checking that things went as
> expected)

That's another reason to avoid "assert" in the name: these methods
*don't* necessarily use the 'assert' statement. Avoiding the
implication that they do use that is a good thing.

-- 
 \     “Never do anything against conscience even if the state demands |
  `\                                             it.” —Albert Einstein |
_o__)                                                                  |
Ben Finney

_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to