On Tue, Apr 25, 2017 at 8:05 PM, Ryan Gonzalez <[email protected]> wrote: > def ___init__(self, self.attr):
I'm not a python developer, I'm just a developer that uses python. That said, I really like this form. It eliminates most of the redundancy, while still being explicit. It's true that you have to repeat the 'self' name, but it feels like the right balance in my mind. It seems like anyone who's familiar with python function definitions would immediately grasp what's going on. -- Jerry _______________________________________________ Python-ideas mailing list [email protected] https://mail.python.org/mailman/listinfo/python-ideas Code of Conduct: http://python.org/psf/codeofconduct/
