On 05/17/2017 06:20 AM, Stephan Houben wrote:
class MyClass:
foo = attr.ib()
MyClass = attr.s(MyClass)
Given that one of Python's great strengths is its readability, I would
not use the attr library in teaching because it is not. Having a dot in
the middle of words is confusing, especially when you don't already have
a basis for which abbreviations are common. Is it attr.ib or att.rib or
at.trib?
--
~Ethan~
_______________________________________________
Python-ideas mailing list
Python-ideas@python.org
https://mail.python.org/mailman/listinfo/python-ideas
Code of Conduct: http://python.org/psf/codeofconduct/