29.03.19 20:52, Brett Cannon пише:
On Thu, Mar 28, 2019 at 10:53 AM Serhiy Storchaka <storch...@gmail.com <mailto:storch...@gmail.com>> wrote:

    28.03.19 19:45, Brett Cannon пише:
     > So I would say that a cache-clearing function convention would be a
     > reasonable starting point. If that turns out to not be enough for
    folks
     > we can talk about expanding it, but I think we should start small
    and
     > grow from there as needed.
     >
     > So what name would people want. clear_cache() or _clear_cache()? I
     > personally prefer the latter since clearing the cache shouldn't be
     > something people should typically need to do and thus the
    function is an
     > implementation detail.

    This is an interesting idea. I think it should be a dunder name:
    __clearcache__() or __clear_cache__().


Between those two then I would go with __clearcache__(), but I was talking about a naming scheme for a function in each module, not a new built-in in case you thought I meant that.

Then I understood you correctly. Only now I saw that your words could have been understood differently.

Opened https://bugs.python.org/issue36485 for implementing this idea.

_______________________________________________
Python-ideas mailing list
Python-ideas@python.org
https://mail.python.org/mailman/listinfo/python-ideas
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to