Steven D'Aprano wrote:
The best thing is that there will no longer be any confusion as to whether you are looking at a Unicode string or a byte-string:

    a = a.new_string_trimmed_on_the_left()
    a = a.new_bytes_trimmed_on_the_left()

To keep the RUE happy, instead of a "string" we should call it a
"mathematically_valid_encoded_code_point_sequence".

--
Greg
_______________________________________________
Python-ideas mailing list
Python-ideas@python.org
https://mail.python.org/mailman/listinfo/python-ideas
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to