On Mon, Feb 15, 2021 at 5:21 PM Paul Bryan <[email protected]> wrote:

> I wonder how that is substantially different than:
>


> or perhaps more verbosely, but arguably more readable:
>
> from pathlib import Path
>
> Path() / "foo"
>
> or

from pathlib import Path
Path("foo")

I guess I don't find the proposal or variation worth it to me -- though I
guess it's easier when you are translating code that uses string paths
already -- but not much easier.

-CHB

-- 
Christopher Barker, PhD (Chris)

Python Language Consulting
  - Teaching
  - Scientific Software Development
  - Desktop GUI and Web Development
  - wxPython, numpy, scipy, Cython
_______________________________________________
Python-ideas mailing list -- [email protected]
To unsubscribe send an email to [email protected]
https://mail.python.org/mailman3/lists/python-ideas.python.org/
Message archived at 
https://mail.python.org/archives/list/[email protected]/message/QY72VXTDW7CIEBPYN6HO6EBNR7XFA72U/
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to