Roy Smith wrote:
You want something like

self.assertRaises(AttributeError, lambda: self.combat.value = 1)

Or, combining the two responses and avoiding the lambda:

 self.assertRaises(AttributeError, setattr, self.combat, 'value', 1)

Hmm... this might be a case where the lambda form is actually the
more readable one...

-Peter
--
http://mail.python.org/mailman/listinfo/python-list

Reply via email to