[following up late] In article <2b3c916e-6908-4b12-933f-8f7bfa86c...@i20g2000prf.googlegroups.com>, Russ P. <russ.paie...@gmail.com> wrote: > >Fair enough, but for code that is not intended for general public >usage (i.e., most code) so-called camelCase is every bit as good if >not better than using underscores to divide variable names. It saves a >few characters, and in my opinion it's significantly easier to read. >Identifiers divided by underscores always appear to me at first glance >to be multiple words, and I find that very annoying. > >So unless you think the standard library will someday include code for >air traffic management, I'll stick with camelCase, and I'll thank you >for not making an issue of it.
You are missing the point: suppose you write a useful library in your air traffic management application, maybe one that does a good job of handling user input. If you have done a proper job of abstracting it from your application as a whole, you could easily publicize it, but it will never get into the standard library unless it meets current PEP8 guidelines. Why fuss about trying to figure out which parts of your application might in the future be published? -- Aahz (a...@pythoncraft.com) <*> http://www.pythoncraft.com/ "Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." --Brian W. Kernighan -- http://mail.python.org/mailman/listinfo/python-list