On 10/20/10 22:09, Seebs wrote:
On 2010-10-20, Matteo Landi<landima...@gmail.com>  wrote:
Another situation in which I needed to disable such kind of warnings
is while working with graphics modules.
I often use variable names such as x, y, z for coordinates, or r,g,b for colors.
Would longer names make the reader's life easier?

Interesting point.  Which is really easier to read:

        x, y, z = p.nextpoint()

        xCoordinate, yCoordinate, zCoordinate = polygon.nextPointCoordinates()

-s

Although intuitively I would say the shorthand, however that is depending on the context being me knowing at least the basics of 3d spaces and having the pre-warning that you are going to mention something with either coordinates or colours.

Take away this pre-information, as you would when first reading an application, and all of the sudden the latter would be much clearer to the fellow programmer.

--
mph
--
http://mail.python.org/mailman/listinfo/python-list

Reply via email to