On Sat, Nov 6, 2021 at 8:42 AM Betty Hollinshead <lizzyhollin...@gmail.com> wrote: > > python3-3.10.0-1.fc35.x86_64 > alacarte-3.36.0-6.fc35.noarch > > Someone in the Python world changed the name of an import. > Once upon a time the import (in alacarte) it looked like this: > from collections import Sequence > > In a standard Fedora 35 install a few days ago, alacarte crashes. > ....because the import (now) needs to look like this: > from collections.abc import Sequence > > Am I alone in wondering about this sort of stupid change of name? >
Calling it "stupid" isn't a great way to get a useful discussion. I would say that alacarte has been buggy for the better part of a decade, and you're only now getting an actual error. Here's the change - it wasn't a rename at all: https://docs.python.org/3/whatsnew/3.9.html#you-should-check-for-deprecationwarning-in-your-code The "collections.Sequence" alias has been kept for backward compatibility, but as of 3.10, has been removed. The correct spelling, "collections.abc.Sequence", has been valid since at least 2012 (that's when it started emitting a warning - don't know if it was available longer and I don't have a Python 3.2 to test). So either alacarte hasn't been updated in many many years, or nobody has bothered to check the warnings. Maybe, rather than calling the Python devs "stupid", you should consider sending pull requests to projects you use, fixing things that are raising warnings? ChrisA -- https://mail.python.org/mailman/listinfo/python-list