A lot of parts looks like a doc duplication from 
https://www.mediawiki.org/wiki/Manual:Pywikibot/Development, some other hints 
are found at https://www.mediawiki.org/wiki/Manual:Pywikibot/Installation.

I propose not to duplicate neither the installation part nor the step by step 
example. The developer guideline should be a guideline for code style (pep20, 
pep8, pep257), naming convention, reviewing and guidelines using command line 
arguments etc.

I find a good samples for coding guidlines are 
http://google-styleguide.googlecode.com/svn/trunk/pyguide.html and 
http://docs.python-guide.org/en/latest/writing/style/

Greetings
xqt




----- Original Nachricht ----
Von:     Amir Ladsgroup <ladsgr...@gmail.com>
An:      Pywikipedia discussion list <pywikipedia-l@lists.wikimedia.org>
Datum:   17.05.2014 18:42
Betreff: Re: [Pywikipedia-l] Guideline for codes of PWB

> I finished writing the guideline:
> https://www.mediawiki.org/wiki/Manual:Pywikibot/Development_guideline
> Reading the pep8 about naming style was interesting. (as pep8 name of our
> project has to be "pywikibot" not "Pywikibot", or "PyWikiBot")
> 
>    - Names of classes has to be CapWord (use DataPage instead of Datapage,
>    datapage or data_page)
>    - Names of functions and methods has to be lowercase with underscores
>    for better readability (e.g. set_label instead setLabel, or SetLabel)
>    - Names of errors has to be CapWord with "Error" suffix (like
>    NoPageError)
> 
> 
> Please anyone check the page and if we can reach a consensus about the
> guideline, we'll start enforcing it and adding it to pages.
> Please feel free to edit (and add things) mercilessly
> Best
> 
> 
> 
> On Fri, May 16, 2014 at 6:26 PM, Amir Ladsgroup <ladsgr...@gmail.com>
> wrote:
> 
> > a huge part of pep8 is dedicated to the naming style:
> > http://legacy.python.org/dev/peps/pep-0008/#id26
> > for example names of functions has to be lowercase and name of classes
> has
> > to be CamelCase, etc.
> >
> >
> > On Fri, May 16, 2014 at 1:09 PM, Pyfisch <pyfi...@googlemail.com> wrote:
> >
> >> I just want to mention a discussion about lowercase_with_underscores and
> >> mixedCase: https://gerrit.wikimedia.org/r/#/c/105173/ I agree that it
> >> should be consistent and everything changed to a single standard, I
> would
> >> prefer lowercase_with_underscores.
> >>
> >> Best
> >>
> >>
> >> _______________________________________________
> >> Pywikipedia-l mailing list
> >> Pywikipedia-l@lists.wikimedia.org
> >> https://lists.wikimedia.org/mailman/listinfo/pywikipedia-l
> >>
> >
> >
> >
> > --
> > Amir
> >
> >
> 
> 
> -- 
> Amir
> 
> 
> --------------------------------
> 
> _______________________________________________
> Pywikipedia-l mailing list
> Pywikipedia-l@lists.wikimedia.org
> https://lists.wikimedia.org/mailman/listinfo/pywikipedia-l
> 

_______________________________________________
Pywikipedia-l mailing list
Pywikipedia-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/pywikipedia-l

Reply via email to