On Wed, Dec 05, 2018 at 05:46:58PM +0300, Vladimir Sementsov-Ogievskiy wrote: > Rename qcrypto_block_*crypt_helper to qcrypto_cipher_*crypt_helper, as > it's not about QCryptoBlock. This is needed to introduce > qcrypto_block_*crypt_helper in the next commit, which will have > QCryptoBlock pointer and than will be able to use additional fields of > it, which in turn will be used to implement thread-safe QCryptoBlock > operations.
The naming convention I'm following is that methods defined in a file should all use the name of the file as their prefix. Hence everything in crypto/block.* should be named with a qcrypto_block_ prefix > > Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com> > --- > crypto/blockpriv.h | 34 +++++++++++++------------- > crypto/block-luks.c | 44 +++++++++++++++++----------------- > crypto/block-qcow.c | 16 ++++++------- > crypto/block.c | 58 ++++++++++++++++++++++----------------------- > 4 files changed, 76 insertions(+), 76 deletions(-) > > diff --git a/crypto/blockpriv.h b/crypto/blockpriv.h > index 41840abcec..347a7c010a 100644 > --- a/crypto/blockpriv.h > +++ b/crypto/blockpriv.h > @@ -78,22 +78,22 @@ struct QCryptoBlockDriver { > }; > > > -int qcrypto_block_decrypt_helper(QCryptoCipher *cipher, > - size_t niv, > - QCryptoIVGen *ivgen, > - int sectorsize, > - uint64_t offset, > - uint8_t *buf, > - size_t len, > - Error **errp); > - > -int qcrypto_block_encrypt_helper(QCryptoCipher *cipher, > - size_t niv, > - QCryptoIVGen *ivgen, > - int sectorsize, > - uint64_t offset, > - uint8_t *buf, > - size_t len, > - Error **errp); > +int qcrypto_cipher_decrypt_helper(QCryptoCipher *cipher, > + size_t niv, > + QCryptoIVGen *ivgen, > + int sectorsize, > + uint64_t offset, > + uint8_t *buf, > + size_t len, > + Error **errp); > + > +int qcrypto_cipher_encrypt_helper(QCryptoCipher *cipher, > + size_t niv, > + QCryptoIVGen *ivgen, > + int sectorsize, > + uint64_t offset, > + uint8_t *buf, > + size_t len, > + Error **errp); Rather than dropping 'block' from the method name, just add 'cipher'. eg qcrypto_block_cipher_decrypt_helper qcrypto_block_cipher_encrypt_helper Regards, Daniel -- |: https://berrange.com -o- https://www.flickr.com/photos/dberrange :| |: https://libvirt.org -o- https://fstop138.berrange.com :| |: https://entangle-photo.org -o- https://www.instagram.com/dberrange :|