On Tue, Jan 18, 2022 at 11:27:33AM -0500, Emanuele Giuseppe Esposito wrote: > diff --git a/block/io.c b/block/io.c > index 5123b7b713..9d5167f64a 100644 > --- a/block/io.c > +++ b/block/io.c > @@ -244,6 +244,7 @@ typedef struct { > bool begin; > bool recursive; > bool poll; > + bool unlock; > BdrvChild *parent; > bool ignore_bds_parents; > int *drained_end_counter; ... > @@ -473,23 +477,35 @@ static void bdrv_do_drained_begin(BlockDriverState *bs, > bool recursive, > */ > if (poll) { > assert(!ignore_bds_parents); > - BDRV_POLL_WHILE(bs, bdrv_drain_poll_top_level(bs, recursive, > parent)); > + if (unlock) {
"Unlock" is a verb that suggests we'll perform an unlock operation. Please call it "unlocked" instead. > + BDRV_POLL_WHILE_UNLOCKED(bs, > + bdrv_drain_poll_top_level(bs, recursive, > + parent)); > + } else { > + BDRV_POLL_WHILE(bs, > + bdrv_drain_poll_top_level(bs, recursive, > parent)); > + } > } > }
signature.asc
Description: PGP signature