pet...@redhat.com writes: > From: Peter Xu <pet...@redhat.com> > > This field, no matter whether on src or dest, is only used for debugging > purpose. > > They can even be removed already, unless it still more or less provide some > accounting on "how many packets are sent/recved for this thread". The > other more important one is called packet_num, which is embeded in the > multifd packet headers (MultiFDPacket_t). > > So let's keep them for now, but make them much easier to understand, by > doing below: > > - Rename both of them to packets_sent / packets_recved, the old > name (num_packets) are waaay too confusing when we already have > MultiFDPacket_t.packets_num. > > - Avoid worrying on the "initial packet": we know we will send it, that's > good enough. The accounting won't matter a great deal to start with 0 or > with 1. > > - Move them to where we send/recv the packets. They're: > > - multifd_send_fill_packet() for senders. > - multifd_recv_unfill_packet() for receivers. > > Signed-off-by: Peter Xu <pet...@redhat.com>
Reviewed-by: Fabiano Rosas <faro...@suse.de>