Daniel P. Berrangé <berra...@redhat.com> writes: > This updates the QAPI code generation to refer to 'features' instead > of 'special_features', in preparation for generalizing their exposure. > > Signed-off-by: Daniel P. Berrangé <berra...@redhat.com>
Have you considered squashing this into the previous patch? [...] > diff --git a/scripts/qapi/gen.py b/scripts/qapi/gen.py > index 6a8abe0041..e6c80cce23 100644 > --- a/scripts/qapi/gen.py > +++ b/scripts/qapi/gen.py > @@ -40,10 +40,10 @@ > from .source import QAPISourceInfo > > > -def gen_special_features(features: Sequence[QAPISchemaFeature]) -> str: > - special_features = [f"1u << QAPI_{feat.name.upper()}" > - for feat in features if feat.is_special()] > - return ' | '.join(special_features) or '0' > +def gen_features(features: Sequence[QAPISchemaFeature]) -> str: > + features = [f"1u << QAPI_{feat.name.upper()}" > + for feat in features if feat.is_special()] > + return ' | '.join(features) or '0' This generates a bitwise or of unsigned operands. Shouldn't we change the operands to uint64_t? > > > class QAPIGen: [...]