On 04/18/2012 02:55 PM, Eduardo Habkost wrote:
This is just a rebase of v4, because I noticed that v4 doesn't apply cleanly
against current git master anymore (and I will soon submit a series that will
depend on this one).

Changes v4 ->  v5:
  - Rebase against latest qemu.git

Changes v3 ->  v4:
  - Rebase against latest qemu.git
  - Changed patch 14/14 subject to match the code (--with-confsuffix instead of 
--confsuffix)

Changes v2 ->  v3:
  - Changes --datadir meaning to match Autoconf convention
    (meaning that it should point to /usr/share, not /usr/share/qemu).
    NOTE: this breaks compatibility.
    I don't know of anybody who uses that option today. Neither Fedora, Debian,
    Arch Linux, Gentoo, or FreeBSD use it[1].
  - Add --with-confsuffix option, to allow the /etc/qemu and /usr/share/qemu
    directories to have a different names.

Applied.  Thanks.

Regards,

Anthony Liguori


[1] http://article.gmane.org/gmane.comp.emulators.qemu/142924


Series description:

Most of the patches are variable renames and cleanups. The actual changes are
only on the last 2 patches.

First, internal configure variables are renamed, without changing
config-host.mak:

   configure: rename $datadir to $qemu_datadir
   configure: rename $docdir to $qemu_docdir
   configure: rename $confdir to $qemu_confdir

Then create_config gets ready for config-host.mak variable renames
(Qemu-specific directories will now have a "qemu_" prefix):

   create_config: separate section for qemu_*dir variables (v2)

Then, variables are renamed on config-host.mak and Makefiles:

   config-host.mak: rename datadir to qemu_datadir
   config-host.mak: rename confdir to qemu_confdir
   Makefile: use $(qemu_confdir) instead of $(sysconfdir)/qemu
   config-host.mak: rename docdir to qemu_docdir
   config-host.mak: remove CONFIG_QEMU_SHAREDIR
   config-host.mak: reorder variables a bit

Then old code on create_config is removed:

   create_config: remove *dir block
   create_config: simplify prefix=* block, remove CONFIG_QEMU_PREFIX

Finally, the user-visible changes:

   configure: change meaning of --datadir to Autoconf convention
   configure: add --with-confsuffix option



Eduardo Habkost (14):
   configure: rename $datadir to $qemu_datadir
   configure: rename $docdir to $qemu_docdir
   configure: rename $confdir to $qemu_confdir
   create_config: separate section for qemu_*dir variables (v2)
   config-host.mak: rename datadir to qemu_datadir
   config-host.mak: rename confdir to qemu_confdir
   Makefile: use $(qemu_confdir) instead of $(sysconfdir)/qemu
   config-host.mak: rename docdir to qemu_docdir
   config-host.mak: remove CONFIG_QEMU_SHAREDIR
   config-host.mak: reorder variables a bit
   create_config: remove *dir block
   create_config: simplify prefix=* block, remove CONFIG_QEMU_PREFIX
   configure: change meaning of --datadir to Autoconf convention
   configure: add --with-confsuffix option

  Makefile              |   16 ++++++++--------
  Makefile.target       |    4 ++--
  configure             |   29 ++++++++++++++++-------------
  scripts/create_config |    8 ++++++--
  4 files changed, 32 insertions(+), 25 deletions(-)



Reply via email to