Hi Guan,

>  /* These instructions trap after executing, so defer them until after the
>     conditional executions state has been updated.  */
> @@ -1551,12 +1558,12 @@ static void do_misc(CPUUniCore32State *env, 
> DisasContext *s, uint32_t insn)
>  /* load/store I_offset and R_offset */
>  static void do_ldst_ir(CPUUniCore32State *env, DisasContext *s, uint32_t 
> insn)
>  {
> -    unsigned int i;
> +    unsigned int mmuindex;
                    ^^^^^^^^
   I would suggest you to rename it to mmu_idx or something like that. :)

Regards,
chenwj

-- 
Wei-Ren Chen (陳韋任)
Computer Systems Lab, Institute of Information Science,
Academia Sinica, Taiwan (R.O.C.)
Tel:886-2-2788-3799 #1667
Homepage: http://people.cs.nctu.edu.tw/~chenwj

Reply via email to