The current ppc_mpc8544ds.c is split into a generic (eventually) e500 backend, and two platform frontends (mpc8544ds and a generic paravirt e500 platform) that instantiate the backend.
Currently the only distinction between the subplatforms is toplevel compatible and model in the device tree (the generic e500 backend isn't very generic yet), but additional refactoring should happen in the future. Scott Wood (4): PPC: e500: rename mpc8544ds into generic file PPC: e500: change internal references away from mpc8544ds PPC: e500: split mpc8544ds machine from generic e500 code PPC: e500: add generic e500 platform hw/ppc/Makefile.objs | 3 +- hw/{ppce500_mpc8544ds.c => ppc/e500.c} | 110 +++++++++++++------------------ hw/ppc/e500.h | 21 ++++++ hw/ppc/e500plat.c | 60 +++++++++++++++++ hw/ppc/mpc8544ds.c | 61 ++++++++++++++++++ 5 files changed, 190 insertions(+), 65 deletions(-) rename hw/{ppce500_mpc8544ds.c => ppc/e500.c} (88%) create mode 100644 hw/ppc/e500.h create mode 100644 hw/ppc/e500plat.c create mode 100644 hw/ppc/mpc8544ds.c -- 1.7.5.4