On Fri, 10 Jul 2026 at 14:37, Philippe Mathieu-Daudé <[email protected]> wrote: > > On 10/7/26 12:59, Peter Maydell wrote: > > omap_dma.h is the header file for hw/dma/omap_dma.c; it fits better > > to put it in include/hw/dma/ to match where we have the .c file. > > > > Signed-off-by: Peter Maydell <[email protected]> > > --- > > hw/arm/omap1.c | 2 +- > > hw/dma/omap_dma.c | 2 +- > > hw/dma/soc_dma.c | 2 +- > > include/hw/{arm => dma}/soc_dma.h | 0 > > 4 files changed, 3 insertions(+), 3 deletions(-) > > rename include/hw/{arm => dma}/soc_dma.h (100%) > > Per the cover letter, "The omap_dma device is the only user of > the soc_dma code", then maybe take the rename opportunity to > name as omap_dma.h?
It's the only user but it is still a separate C file, so I think we should keep soc_dma.h to match the soc_dma.c filename. -- PMM
