Hi,
> > + if (uv->used_storage > uv->max_storage) {
> > + error_report("out of variable memory (%ld > %ld)",
>
> nit: what about replacing %ld with PRIu64?
Done.
> > +static int uefi_vars_post_load(void *opaque, int version_id)
> > +{
> > + uefi_variable *var = opaque;
> > +
> > + if (!uefi_str_is_valid(var->name, var->name_size, true) ||
> > + var->attributes & ~EFI_VARIABLE_ATTRIBUTE_SUPPORTED ||
> > + (var->digest_size != 0 &&
> > + var->digest_size != 32 /* AUTHVAR_DIGEST_SIZE */)) {
>
> is it worth moving that define to a common header and using it here?
Was thinking about that too, but I'd prefer to keep the AUTHVAR_DIGEST_*
#defines together and the other has a dependency on gnutls so I can't
move it around easily.
take care,
Gerd