On Fri, Aug 21, 2026 at 10:10:40AM -0400, Peter Xu wrote:
> > +    switch (wr_id) {
> > +    case RDMA_WRID_RDMA_WRITE:
> > +        wr_desc = "RDMA write";
> > +        break;
> > +    case RDMA_WRID_SEND_CONTROL:
> > +        wr_desc = "control send";
> > +        break;
> > +    default:
> > +        wr_desc = "send work request";
> > +        break;
> 
> Do we have other possibility?  I thought it should be either WRITE or SEND,
> if so, we could g_assert_not_reached().

Some side discussion..

Since we're talking about the wrids, IIUC the whole RDMA wrid space is a
bit messy. E.g. RDMA_WRID_SEND_CONTROL is used without having
RDMA_WRID_CONTROL (2000, rather than 2022) for SEND control messages.

IIUC the two-layered wrid name space is confusing, maybe we can rewrite the
wrid allocation to only use one namespace with very limited wrid
possibilities, selecting rdma->wr_data[] index based on the few
possibilities.  My gut feeling is that's much easier to read.

In all cases, this will be a separate discussion, not relevant to this
series alone, but I want to see if I'm the only one got confused by these
two-layered RDMA_WRID_*.

Thanks,

-- 
Peter Xu


Reply via email to