On 28/8/26 00:25, Daniel Henrique Barboza wrote:
Given that the helpers are public API we should prefix them with
"riscv_" to avoid conflicts when linking with different targets in the
future, i.e. we should not use generic names like
"create_fdt_socket_memory".

Despite the amount of lines this is a mechanical change and no real
FDT changes are intended.

Suggested-by: Philippe Mathieu-Daudé <[email protected]>
Signed-off-by: Daniel Henrique Barboza <[email protected]>
---
  hw/riscv/fdt-common.c         | 45 ++++++++++++++++----------------
  hw/riscv/sifive_u.c           | 34 +++++++++++++------------
  hw/riscv/spike.c              | 30 ++++++++++++----------
  hw/riscv/tt_atlantis.c        | 22 ++++++++--------
  hw/riscv/virt.c               | 42 +++++++++++++++---------------
  include/hw/riscv/fdt-common.h | 48 ++++++++++++++++++-----------------
  6 files changed, 117 insertions(+), 104 deletions(-)

Thank you!

Reviewed-by: Philippe Mathieu-Daudé <[email protected]>

Reply via email to