On Mon, Sep 07, 2026 at 09:20:08AM +0000, Jamin Lin wrote: > The ASPEED vendor id is already listed. Add 0x2000, the device id the > display controller of the ASPEED BMC SoCs reports, so that the model > added by the next patch can use it. > > No functional change. > > Signed-off-by: Jamin Lin <[email protected]> > --- > include/hw/pci/pci_ids.h | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/include/hw/pci/pci_ids.h b/include/hw/pci/pci_ids.h > index 16034aaa2c..e16d93dd13 100644 > --- a/include/hw/pci/pci_ids.h > +++ b/include/hw/pci/pci_ids.h > @@ -292,5 +292,6 @@ > #define PCI_VENDOR_ID_NVIDIA 0x10de > > #define PCI_VENDOR_ID_ASPEED 0x1A03 > +#define PCI_DEVICE_ID_ASPEED_VGA 0x2000 > > #endif
you do not really need it, it should only be used in one place. open-code the dev id in the implementation. subsystem id will be copied automatically if not set. > -- > 2.53.0 >
