> Set TYPE_VIRT_MACHINE to MACHINE_TYPE_NAME("or1k-virt") so OpenRISC
> virt no longer collides with other virt-machine types in one process.
> Keep the -M / help / migration name as virt via
> machine_class_set_name().
> 
> Signed-off-by: Yonggang Luo <[email protected]>
> Message-ID: <[email protected]>
>
> diff --git a/hw/or1k/virt.c b/hw/or1k/virt.c
> index 2ff5c084a2b7..35884252379c 100644
> --- a/hw/or1k/virt.c
> +++ b/hw/or1k/virt.c
> @@ -34,7 +34,7 @@
>  #define VIRT_CPUS_MAX 4
>  #define VIRT_CLK_MHZ 20000000
>  
> -#define TYPE_VIRT_MACHINE MACHINE_TYPE_NAME("virt")
> +#define TYPE_VIRT_MACHINE MACHINE_TYPE_NAME("or1k-virt")
>  #define VIRT_MACHINE(obj) \
>      OBJECT_CHECK(OR1KVirtState, (obj), TYPE_VIRT_MACHINE)

While at it, rename it to TYPE_OR1K_VIRT_MACHINE?

>  
> @@ -548,6 +548,7 @@ static void openrisc_virt_machine_init(ObjectClass *oc, 
> const void *data)
>      MachineClass *mc = MACHINE_CLASS(oc);
>  
>      mc->desc = "or1k virtual machine";
> +    machine_class_set_name(mc, "virt");
>      mc->init = openrisc_virt_init;
>      mc->max_cpus = VIRT_CPUS_MAX;
>      mc->is_default = false;

Reviewed-by: Marc-André Lureau <[email protected]>

-- 
Marc-André Lureau <[email protected]>


Reply via email to