On 28/9/26 07:20, Yonggang Luo wrote:
Add RX_EXCP_* in cpu.h for the guest trap numbers stored in
cs->exception_index.
Signed-off-by: Yonggang Luo <[email protected]>
---
target/rx/cpu.h | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/target/rx/cpu.h b/target/rx/cpu.h
index 64ba48a7329..521e494172e 100644
--- a/target/rx/cpu.h
+++ b/target/rx/cpu.h
@@ -71,6 +71,16 @@ enum {
NUM_REGS = 16,
};
+/* Guest trap numbers. */
+enum {
+ RX_EXCP_PRIVILEGE_VIOLATION = 20,
+ RX_EXCP_ACCESS = 21,
+ RX_EXCP_ILLEGAL_INSTRUCTION = 23,
+ RX_EXCP_FPU = 25,
+ RX_EXCP_NMI = 30,
+ RX_EXCP_INT = 0x100,
+};
Thanks for splitting in a previous patch, but we want to
add the definitions and replace the magic values at the
same time (i.e. the changes in rx_cpu_do_interrupt() in
the next patch go here), but also s/21/RX_EXCP_ACCESS/ in
update_fpsw, etc...).